Cyclone3 Skin

System Requirements

From Cyclone3 Wiki

System

Minimal:

  • POSIX operating system - Linux/*BSD/Solaris with root access
  • Perl 5.8.*
  • MySQL >= 4.1 (optional 5.0 +InnoDB)
  • Apache2 (+mod_fastcgi/+mod_fcgid)
  • subversion (+perl)
  • memcached (+perl)

Optional or required:

  • mencoder
  • ffmpeg

Perl libs

Minimal:

  • Inline
  • CGI::Fast
  • DBI
  • DBD::Mysql
  • MIME::Entity
  • >=Proc::ProcessTable-0.41
  • DateTime
  • Params::Validate
  • Text::Iconv
  • File::Type
  • Geo::IP
  • Prallel::ForkManager
  • String::CRC32
  • Compress::Zlib
  • XML::Generator
  • XML::XPath
  • SOAP::Lite

Required by extended features:

  • Inline::Java
  • Net::IRC
  • SVG
  • XML::Sablotron
  • XML::LibXML

Oracle

When you are using connection to Oracle with DBD::Oracle, you will patche file oci8.c for utf-8 support

case  96:                               /* CHAR         */
        fbh->disize = fbh->dbsize*4;
        if (CS_IS_UTF8(fbh->csid))
            fbh->disize = fbh->dbsize * 4;
        fbh->prec   = fbh->disize;
        break;